LNMP一键包增加系统支持(Linux Mint)

我们使用网上的LNMP一键包的时候,总会有这样那样的问题,比如系统不支持,内存不够,巴拉巴拉。

近期桌面端的开发环境换成了Linux Mint,在使用LNMP一键包的时候,会提示系统不支持,但是LinuxMint是Ubuntu的开发版(网上是这个说的),所以支持Ubuntu的的软件巴拉巴拉的都应该是支持LinuxMint的,所以我们修改了脚本,让脚本能够支持这个系统。

Ex:

oneinstack的一键安装包:

在oneinstack/include目录下,可以找到check_os.sh,这个脚本就是检测系统是否合格的。

我们在这一行修改,添加:

elif [ -n "`grep Ubuntu /etc/issue`" -o "`lsb_release -is 2>/dev/null`" == 'Ubuntu' ] || [ -n "`grep Mint /etc/issue`" -o "`lsb_release -is 2>/dev/null`" == 'LinuxMint' ];then

再加入这句话之后,在判断系统的时候,就可以将LinuxMint识别为Ubuntu。

※转载保留版权:糖果果|Sugarguo
※本文链接地址:
http://www.sugarguo.com/lnmpyijianbaozengjiaxitongzhichilinuxmint/
※除非注明,糖果果|Sugarguo文章均为原创
※英雄不问来路,转载请注明出处和链接,谢谢。
※如果喜欢可以:点此订阅本站

发布者

糖果果|Sugarguo

一只欢乐的逗霸,逗比中的战斗机~学习vps,linux,python,c#,嵌入式~

发表评论

电子邮件地址不会被公开。 必填项已用*标注